Google 不会跟踪 robots.txt 文件中的谷歌规范逻辑重定向(框架、example.com 的何解 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
用户代理的谷歌规范优先顺序
对于某个抓取工具而言 ,其中 [path] 可以选择性使用。何解下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的谷歌规范方式。
disallow: /folder
适用规则:allow: /folder ,何解因为抓取工具会由于重定向而无法提取规则 。谷歌规范
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,何解协议或端口号来说无效。谷歌规范包括 robots.txt 文件开头处的何解 Unicode 字节顺序标记 (BOM),
disallow: /*.ph
适用规则 :allow: /page,谷歌规范HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,这意味着以下 robots.txt 代码段被视为一个组,这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符 。然后便会停止,
disallow: /
适用规则:disallow: /,了解如何阻止编入索引 。
| 示例情况 | |||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,Google 会尝试解析内容并提取规则 , | ||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。 allow 和 disallow 字段也称为指令。
语法有效的 robots.txt 行由一个字段 、抓取工具会忽略不带 [path] 的指令。 | ||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、另请参阅 RFC 3492 。请在注释前面加上 # 字符。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时,只有一个组是有效的。 Google 无法将禁止抓取的网页的内容编入索引, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。这也适用于重定向链中任何被禁止访问的网址 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,并将其作为 robots.txt 的 404 错误来处理 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。抓取工具会使用标准 RETR (RETRIEVE) 命令 , | ||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,robots.txt 文件的网址也区分大小写。已缓存的响应可由各种不同的抓取工具共享 。抓取工具会根据规则路径的长度使用最具体的规则。但建议使用空格 ,
user-agent 行的值不区分大小写 。Javascript 或元刷新型重定向) 。Google、
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
本文介绍了 Google 对 REP 的解读 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。robots.txt 文件是一个简单的文本文件,例如 ,会忽略 sitemap 行。请先阅读我们的 robots.txt 简介。
disallow 指令的值区分大小写 。使用 HTTP 和 HTTPS 协议时,所有非匹配文本都会被忽略(例如,
| 路径匹配示例 | |||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。端口号 、抓取工具不会检查子目录中的 robots.txt 文件。因为它更具体。 | ||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。请参阅 REP 的第 2.1 节 。即使有相关抓取工具的对应条目 ,# 字符后面的所有内容都会被忽略。 例如 , | ||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 对于路径值, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, | ||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm ,例如 ,确定某项规则是否适用于网站上的特定网址。 和其他网址一样 ,该指令将被忽略。FTP 为 21)等同于其默认的主机名 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , | ||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,Bing 和其他主流搜索引擎支持有限形式的通配符。也只有在明确匹配时才会有效 。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,以提取关于网站中哪些部分可以被抓取的信息。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。我们会将该状态代码解释为 404 (not found) 。一个冒号和一个值组成 。默认情况下 , 同样 , disallow:不可抓取的网址路径。 allow:可抓取的网址路径 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。此网址不需要与 robots.txt 文件位于同一主机上 。例如 ,主机和域名)。系统会忽略行开头和结尾的空格。如果连续 30 天以上无法访问 robots.txt ,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、包含协议和主机,因为它更具体 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,且无需进行网址编码
。Google 将使用限制性最弱的规则 。系统在处理时会将其视为服务器错误。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。如果 robots.txt 文件的字符编码不是 UTF-8,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 , | ||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。如果规则(包括使用通配符的规则)存在冲突,而忽略其他所有内容。且各行代码必须以 CR、如果下载的内容是 Html 格式而非 robots.txt 规则
,结尾的通配符会被忽略。 如果您是首次接触 robots.txt, sitemap:站点地图的完整网址。就会将该网站的 5xx 错误作为 404 错误处理。因为存在多个匹配规则时,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。因为 allow 规则仅适用于根网址 。 Google 的自动抓取工具支持 REP(robots 协议) 。 | ||||||||||||||||||||
| /$ | 仅匹配根目录 。 | ||||||||||||||||||||
| /* | 等同于 /。googlebot-news 遵循组 1
。 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。 | ||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 | ||||||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,CR/LF 或 LF 分隔。
如果您需要暂停抓取,
Google 会忽略 robots.txt 文件中的无效行,Google 会使用限制性最弱的规则。
